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Assembly Strategies Tutorial

Sequencher offers o wide variety of assembly opfions. The most frequently used options, Assemble Automatically, Assemble
Interactively, and Assemble to Reference are available as prominent buttons in the Project window. However, there are
numerous other options under the Assemble menu that may be more suitable for a given project.

In addition to the assembly options described here, investigate the tutorials for Reference Sequence and for Assemble by
Name. The Reference Sequence has a number of special properties that affect the assembly process. Assemble by Name
allows you to further automate the assembly process, providing greater quality control while saving you time.

THE LARGE GAP ASSEMBLY ALGORITHM

The Large Gap algorithm allows you to assemble sequences that are expected to contain insertions and delefions greater
than 10 bases long. Typical examples of assemblies that require the Large Gap algorithm include the assembly of a cDNA
sequence fo a genomic sequence and the assembly of related genes with alternative splicing.

Launch Sequencher.
Go fo the File menu, select Import > Sequencher Project...., and double-click on Large Gap.SPF.

This file contains two sequences, p53 cDNA and p53 genomic sequences.

Click on the Assembly Parameters button.
Click on the Large Gap radio button, then click OK.

Assembly Algorithm
T Dirty Data () Clean Data ® Large Gap

The large gap algorithm is similar to and SLOWER than the
dirty data algorithm. Large sequences of gaps may be inserted
if the candidate sequences contain multiple homologies that are
not contiguous.

Select hoth the cDNA and genomic sequences if they are not already selected.
Click on the Assemble Automatically button.

Sequencher will assemble the cDNA to the genomic sequence in less than one second.

Close out of the Assembly Completed dialog.

Double-click on the Contig[0001] icon to open the Contig Editor Overview.

Make sure that the Motifs and Colors As Backgrounds menu items on the View menu are checked.

To see a graphic representation of the gap alignment, from the Window menu, click on Motif Definitions....

Type a “s" as a Motif and select “Blue” from the Display drop down menu.
(lose the Motifs window.

Now the location of each gap will be highlighted in both the Overview and in the text displays of the sequences.
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Double click on the name of the P53cDNA sequence to open its Sequence Editor.

e 06 p53cDNA

I Overview [ Cut Map ‘ [ Ruler } ’ Find l I Show Experimental 1

i Residue: 1 (Sequenced Strand) Sequence Length: 6961

1 ATGGAGGAGC CGCAGTCAGA TCCTAGCGTC GAGCCCCCTC TGAGTCAGGA m
s1 AACATTTTCA GACCTATGGA AACTHEEEEH FEFEEEERH BEFFRREEE
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50 BEERTCCCCC TTGCCGTCCC AAGCAATGGA TGATTTGATG CTGTCCCCGG
;51 ACGATATTGA ACAATGGTTC ACTGAAGACC CAGGTCCAGA TGAAGCTCCC
w1 AGAATGCCAG AGGCTGCTCC CCGCGTGGCC CCTGCACCAG CAGCTCCTAC
i1 ACCGGCGGCC CCTGCACCAG CCCCCTCCTG GCCCCTGTCA TCTTCTGTCC
son  CTTCCCAGAA AACCTACCAG GGCAGCTACG GTTTCCGTCT GGGCTTCTTG
ss1 CATTCTGGGA CAGCCAAGTC TGTGACTTGC ACGHEEEEEE EEEEEEEER

= [onnoooood Becgggond fooooddcdd [oocood EEEmmmmmnd 00
. [onnoonond Beggggccsd Fogiidddcd Booooocnnd kasoonoond

701

Gaps have been placed in the cDNA in order to assemble the sequence fo the genomic.
(lose the Sequence Editor by dlicking on the close box.
Click on the Bases button to switch from the Overview fo the Bases view.
Place your cursor on the first base in the consensus.
Select Select > Next Ambiguous Base.

Sequencher will bring you fo the beginning and end of each large gap in the assembly with each selection of Next
Ambiguous Base.

From the File menu, select Close Project without saving.

Gene Codes Corporation ©2011 Assembly Strategies p.4of9



ASSEMBLY WITH REALIGNER

Realigner is an optional step that can augment the standard assembly algorithm. The ReAligner function evaluates the
placement of gaps within a contig and optimizes their placement. ReAligner facilitates editing in the consensus sequence and
more clearly displays the effect of insertions and deletions.

[=] No Realigner [ollE )=

A

The sequences in the assemblies above and below are the same. The top contig was assembled without ReAligner. The
bottom contig was assembled with the ReAligner option. Note that the location of the inserted bases is much clearer in the
assembly below than it is in the one above.

IZI Realigner ‘iuﬂl@

i] Overview | Summary | Cut Map Find Redligner

To test the ReAligner option, use the following steps to open the Sequencher Realigner project.

Select File > New Project.
Go fo the File menu, select Import > Sequencher Project. .. and then double-click on Realigner.SPF.

The project contains the two contigs, Realigner and No Realigner.

Select the contig Realigner and dissolve the assembly by choosing Dissolve Contig from the Contig menu.
Dismiss the warning dialog by clicking on the Dissolve Contig button.
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The contig will revert to its original 11 sequences.

To reassemble the contig with the ReAligner option, click on the Assembly Parameters button.

The check boxes to Use ReAligner and Prefer 3’ Gap Placement should be on by default. If not, select
them.

(lick OK.

Ensure that all the sequences from the dissolved contig are still selected.

Click on the Assemble Automatically button.

You will assemble all of the 11 sequences and run the ReAligner in less than one second.
Note: Sequencher assembles and dissolves contigs so quickly that it is easy to optimize assembly parameters and options.

Select the Close button to close the Assembly Completed dialog.
From the File menu, select Close Project without saving.

MINDLESSLY JOIN

Mindlessly Join is the kind of tool that every assembly program ought to have, but very few do. It is the kind of tool that
allows you to really tinker with sequences outside of the conventional sets of algorithms.

From the File menu, select New Project.
Go fo the File menu, select Import > Sequencher Project..., and then double-click on Mindlessly
Join.SPF.

The Project window now contains the sequences for each of the eleven exons of p53. You can use the Mindlessly Join
command to perform a virtual ligation and create a cDNA sequence from these exons by following the steps below.

Use your mouse fo drag a selection box around the exons in the order in which you wish them to assemble.
Select Assemble > Mindlessly Join...

Join To Form Contig

-
—
-
|

( Cancel )

I

Irllllr

Al Left @™ End To End O All Right

Select End to End, then click OK.

Sequencher will build the new contig instantly.
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Double click on the new Contig[0001] icon to open the Overview.

):I;._IMPSSM 528 bp DNA PRI 08-JAN-

HUMPS302 102 bp DNA PRI 08-JAN-
\ HUMPS303 22 bp DN& PRI 08-JAN- 1
; HUMPS304 279 bp DNA PRI 08-JAN-
; HUMPS30S 184 bp DNA PRI 08-JAN-
HUMPS306 1 13’;@}»:.& PRI D8-JaN-
' HUMPS307 110 bp DNA PRI 08-JAN-
; HUMPS308 137 bp DNA PRI 08-JAN-
' HUMPS309 74 bp DN& PRI 08-JAN- 1
' HUMPS310 107 bp DNA PRI 08-JAN-
) HUMPSZ11 1288 bp DNA PRI 08-JAN

1 630 931 1,115 1,338 2,944

Note that there is no overlap between the sequences. The other options, All Left and All Right, are valuable for aligning
sequences that do nof assemble based on standard assembly criteria.

From the File menu, select Close Project and don't save changes when prompted.

ADD SELECTED ITEMS TO OTHERS

Add Selected Items To Others is the favorite algorithm of those working in large sequencing projects. Assemblies of tens of
thousands of sequences are greatly expedited by using this command in liev of the standard, Assemble Automatically
command. Add Selected ltems To Others not only saves you time, but it also gives you more control over the direction of
your assemblies. Uses for this function include genomic sequencing and clustering ESTs.

From the File menu, select New Project.
Go to the File menu, select Import > Sequencher Project..., and select Add Selected ltems.SPF.
Click Open.

The project contains 83 sequences, all related to each other, and all about 1100 bases in length. Qur objective is to identify
which, if any, of the sequences in the project are most closely related to the first sequence in the project - HLA:HLAO00OT.

To do this, modify the Assembly Parameters to require a Minimum Match Percentage of 99%. Click on
the Assembly Parameters button and slide the Minimum Match Percentage control to 99%.

Minimum Match Percentage:

 —
—
| N

60 9100

Click OK to dismiss the dialog.
Select only the sequence HLA:HLAOOOOT icon in the Project window.
Under the Assemble menu, select Add Selected Items To Others.

Sequencher will only assemble the selected sequence with the sequences that match the original selected sequence with a
99% identity.

Gene Codes Corporation ©2011 Assembly Strategies p.70f9



This assembly option is also useful when you have a growing data set. For instance, if you generate 96 new EST sequences
per day, you may wish fo assemble the newly generated sequences to the previously assembled sequences. Newly imported
data is automatically selected in Sequencher. By using the Add Selected Items to Others assembly command, you direct
Sequencher to perform all of the possible comparisons with the new data without repeating the comparisons that you have
already performed with the old data.

Close out of the Assembly Completed dialog.
From the File menu, select Close Project without saving.

ASSEMBLE INTERACTIVELY

The Assemble Interactively option can be used whenever you want the ultimate control in the assembly of a batch of
sequences. The Assemble Interactively window provides you with detailed information regarding overlap, mismatch, and
gapping for any given sequence and a set of candidate sequences. The candidate assemblies are driven by your user-defined
Assembly Parameter setings.

Go to the File menu and select New Project.

Then, from the File menu again, select Import > Sequencher Project... and then select Assemble
Interactively.SPF.

(lick Open.

You will open a project that confains the same 83 sequences that we used in the Add Selected Items project.

Click on the Assembly Parameters button.

Set the following parameters:

> Dirty Data

> ReAligner: Off Prefer 3'Gap Placement: Off

> Minimum Match Percentage: 90%

> Minimum Overlap: 20 bases

> Assemble by Nome: not Enabled

Click OK.

With all of the sequences in the project still selected, click on the Assemble Interactively button.

HLA :HLABBBG2
HLA :HLABBGBG4
HLA :HLABBBGS
HLA :HLAGBBG2
HLA :HLABBBG9
HLA :HLABBa18
HLA :HLABB311
HLA :HLABBG812
HLA :HLABBA14

HLA :HLABBBG1 m

Select the first sequence in the Candidates list.
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The Matches window displays a list of all of the selected sequences that would assemble to the candidate sequence given the
current assembly parameters. The list also displays the %Match, the length of the overlap with the candidate sequence, the
number of mismatches, the number of gaps, and the length of the new contig. The list is sorted by %Match.

Matches #Match Owverlap Mismatch Gaps New Contig Len
HLA :HLAG1496 =99  =1,0938 #1 =0 #1,0898

HLA :HLABBBa4 99  =#1,899 L] #1 #1,0899 m
HLA:HLABG118 =99  #1,098 =4 =@ 1,898

HLA :HLABBB62 =99  =1,0938 =5 =0 #1,0898

HLA :HLABBG43 #98  #1,0938 #12 =@ #1,098
HLA:HLAB1297 =38  #1,893 =13 =0 1,898

HLA :HLABBG47 =38  =1,0938 =14 =0 #1,0898

HLA :HLABBG46 98  #1,098 #14 =@ 1,098

HLA :HLABBG848 =98 #1,098 #18 =@ 1,898 o
HLA :HLABBB3? =38  =1,0938 =19 =0 1,098 v

Select the sequence with only one mismatch, HLA:HLAO1496 in the Matches list.

Sequencher automatically displays the alignment of the selected sequence with the candidate sequence, and provides the
following description of the putative alignment.

RTGGCCGTCATGGCGCCCCGAACCCTCCTCCTGCTACTCTCGGGGGCCCTGGCCCTGACCCAGACCTGGGCGGGLTCO
RTGGCCGTCATGGCGCCCCGAACCCTCCTCCTGCTACTCTCGGGGGCCCTGGCCCTGACCCAGACCTGGGCGGGCTCO
1 lio 120 | BT | PY) Isa lso 170

RTGGCCGTCATGGCGCCCCGAACCCTCCTCCTGCTACTCTCGG6GGCCCTGECCCTGACCCAGACCTGGGCGGGCTCG

The view at the bottom of the window displays and scrolls through the new assembly and the new consensus.

If you choose to create this assembly, click on the Assemble button.
Name the new contig and click OK.

The new contig will appear in the Candidates window and in your Project window.

Close the Assemble Interactively window by dlicking the Done button.
Close the Project without saving and exit Sequencher if desired.
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